Browse News & Discounts
Browse News & DiscountsClose
  • Events Calendar

    See our Events Calendar for a schedule of upcoming BECU community events.

Important News

Website Security Update April 21

You may receive an error message after this change if you’re using an older browser or operating system.

What's Changing

On April 21, 2020, we're updating our systems to remove an outdated version of the security protocol, Transport Layer Security (TLS v1.1). This is an important step to ensure member security when accessing our websites. While we don't anticipate this impacting the majority of our members, we want to make sure you are aware of the change.

To prevent seeing an error message when you log in to Online Banking or visit the website, make sure your web browsers meet the minimum standards below.

Minimum Web Browser Standards

  • Chrome: Version 30 or higher support (with setting changes). No action needed in versions above 70.  Current version is 80.
  • Edge: All versions are compliant
  • Internet Explorer: IE 11 (current version) or higher are compliant.
  • Mozilla: Versions 27-63 support TLS 1.2 with setting changes. No action needed on versions above 63. Current version is 74.
  • Apple Safari: Version 7 or higher

To enable TLS 1.2 protocols or update your web browser, please see the list below for update instructions.

Questions?

If you receive an error message when trying to access our website after April 21, and your OS and browsers are up to date, call a BECU representative at 800-233-2328. You can also send us a secure messaging in Online Banking or the mobile app.